Watch Freeks banner

1 - 6 of 6 Posts

Registered
Joined
223 Posts
Discussion Starter #1
Good morning

I have a Auto relay that is about 15 years old. I took it in to my local watch repair to have a new capacitor put in. They put the new lithium ion capacitor in this auto relay. All seems to work great except when I put the watch on the counter and let it sit. normally it will shut off to save power after three days. I have let it sit for five days and it has not shut off yet. It will however shut off manually by pulling out the crown one position and pushing it back. Is this normal when the battery has been upgraded to the lithium ion.

Thank you very much Roger


Sent from my iPhone using Tapatalk
 

Super Moderator
Joined
9,622 Posts
Good morning, or good afternoon Roger. 馃檪

Yowza, actually sounds like a good problem to have, and like
the battery is just keeping things supercharged. To the point
where the power saving doesn't have to kick in yet, or you
don't have to move, or shake the watch yet.

Maybe someone else can shine a light on things, and totally
put your mind at ease though.

P.S. Just finding this repair site where the gentleman says
the new lithium ion batteries are designed to last much longer. (y)

Here is that link, and where he says this is a few paragraphs
down by the way...

Seiko Kinetic Watch Repair
 

Registered
Joined
1,712 Posts
Good morning, or good afternoon Roger.

Yowza, actually sounds like a good problem to have, and like
the battery is just keeping things supercharged. To the point
where the power saving doesn't have to kick in yet, or you
don't have to move, or shake the watch yet.

Maybe someone else can shine a light on things, and totally
put your mind at ease though.

P.S. Just finding this repair site where the gentleman says
the new lithium ion batteries are designed to last much longer. (y)

Here is that link, and where he says this is a few paragraphs
down by the way...

Seiko Kinetic Watch Repair
Nice find, Tom!


Sent from my iPhone using Tapatalk
 

Registered
Joined
223 Posts
Discussion Starter #5
Thank you very much for the information. I am assuming all is good with my auto relay.

Roger


Sent from my iPhone using Tapatalk
 
1 - 6 of 6 Posts
Top