Watch Freeks banner

1 - 11 of 11 Posts

·
Registered
Joined
·
121 Posts
Discussion Starter #1
I have an Eco Zilla that I wear regularly but haven't worn for a few weeks as I've been working away. Upon my return I noticed it had stopped, so I left it in direct sunlight for well over 24 hours, but still no charge.

Any help would be gratefully appreciated.


Sent from my iPhone using Tapatalk
 

·
Administrator
Joined
·
24,243 Posts

·
Registered
Joined
·
121 Posts
Discussion Starter #3
Cheers dude just emailed the service department. Hopefully it won't be too costly.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
1,178 Posts
Try and pull out crown to reset it first, see if it starts up?


Sent from my iPhone using Crapatalk

Definitely try this (a couple of times if you have to). I was in the same situation, charged mine in sunlight for a couple of days and it was still doing the 2 second jump. Someone on here provided this guidance and as soon as I pulled the crown and reset the time, it started running like a charm.
 

·
Registered
Joined
·
1,888 Posts
Yeah try the reset first, that might do the trick. If not send it for service.
 

·
Registered
Joined
·
121 Posts
Discussion Starter #7
I've had the crown out for 30 seconds then reset the time all whilst in direct sunlight. Still nothing. Shall I pull the crown out and try charging it for a while like that?


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
6 Posts
Pull the crown in and out 2-3 times gently. If it doesn't start working you just might have an issue. I don't think charging it with crown out will make a difference


Sent from my iPhone using Crapatalk
 

·
Registered
Joined
·
121 Posts
Discussion Starter #10
That post is nothing to do with ecozillas haha


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
121 Posts
Discussion Starter #11
Pull the crown in and out 2-3 times gently. If it doesn't start working you just might have an issue. I don't think charging it with crown out will make a difference


Sent from my iPhone using Crapatalk

Cheers dude.


Sent from my iPhone using Tapatalk
 
1 - 11 of 11 Posts
Top